Email Sending Issues
Incident Report for Campaign Monitor
Resolved
Campaign sending has resolved and all Campaigns are sending as expected. Thanks for your patience!
Posted about 1 month ago. Aug 23, 2018 - 12:54 PDT
Investigating
We’re experiencing delays sending emails. Campaigns may see slower processing times. We’re currently investigating.
Posted about 1 month ago. Aug 23, 2018 - 12:09 PDT
This incident affected: Email Sending (Email Campaigns & Journeys).