Issues logging into accounts
Incident Report for Campaign Monitor
Resolved
Please to announce that this has been resolved and all users can now login just fine. Thanks for your patience.
Posted Sep 10, 2020 - 02:54 PDT
Investigating
We're currently looking into reports that customers are experiencing issues when attempting to login to their accounts. As soon as we have more information, we will post it here.
Posted Sep 10, 2020 - 01:58 PDT