Campaign sending issues
Incident Report for Campaign Monitor
Resolved
Campaign sending issues have now been resolved. Thank you for your patience as we worked to resolve the issue.
Posted 9 days ago. Oct 11, 2019 - 11:58 PDT
Identified
Some customers may see campaigns stuck sending. We've identified the issue and working on a solution.
Posted 9 days ago. Oct 11, 2019 - 10:27 PDT
This incident affected: Email Sending (Email Campaigns & Journeys).