Issues accessing Clients page in agency accounts

Performance

Issues accessing Clients page in agency accounts

Status: closed
Start:
End:
Duration: 2 hours 48 minutes
Affected Components:
Web application Log in & access
Update

Some agency account administrators may currently experience issues accessing their Clients page. We are working to resolve this as soon as we can. Thanks for your patience.

Update

We are continuing to work on a fix and will provide further updates. Agency administrators may currently experience issues accessing their Clients page.

Update

We are continuing to work on a fix and will provide further updates. Agency administrators may currently experience issues accessing their Clients page.

Resolved

The incident has now been resolved. Agency administrators should no longer experience issues accessing their Clients page.