Issues creating and editing campaigns

Performance

Issues creating and editing campaigns

Status: closed
Start:
End:
Duration: 42 minutes
Affected Components:
Web application Campaign creation & previews Email builder
Update

We’ve received reports that some customers are having trouble creating and editing campaigns. We are currently investigating and will keep you updated.

Resolved

The incident has now been resolved. Customers should no longer experience any issues when creating and editing campaigns.