Issues with payment processing

Performance

Issues with payment processing

Status: closed
Start:
End:
Duration: 55 minutes
Affected Components:
Web application Payment processing
Update

We’ve received reports that some customers are having trouble making payments and adding new payment cards. We are currently investigating and will keep you updated.

Update

Some customers may currently experience issues making payments and adding new payment cards. We are working to resolve this as soon as we can. Thanks for your patience.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience issues making payments or adding new cards, though we are monitoring results.

Resolved

The incident has now been resolved. Customers should no longer experience issues making payments or adding payment details.