Issues sending campaigns

Performance

Issues sending campaigns

Status: closed
Start:
End:
Duration: 52 minutes
Affected Components:
Email sending Campaign emails
Update

We’ve received reports that some customers are having trouble sending campaigns. We are currently investigating and will keep you updated.

Resolved

The incident has now been resolved. Customers should no longer experience issues with sending campaigns.