Help Center unavailable

Unavailable
May 11, 8:47pm

Help Center unavailable

Status: closed
Start: May 11, 2:38pm
End: May 11, 8:47pm
Duration: 6 hours 9 minutes
Affected Components:
Help Center and contact form
Update

May 11, 2:38pm

May 11, 2:38pm

The Campaign Monitor Help Center may be unavailable for some customers. We are working to resolve this as soon as we can. Thanks for your patience.

Update

May 11, 3:19pm

May 11, 3:19pm

Customers may currently experience issues reaching the Campaign Monitor Help Center.

Update

May 11, 5:45pm

May 11, 5:45pm

The Campaign Monitor Help Center is mostly operational again though there may be some intermittent issues accessing individual help articles. It is expected this should be resolved shortly.

Resolved

May 11, 8:47pm

May 11, 8:47pm

The incident has now been resolved. Customers should no longer experience issues using the Campaign Monitor Help Center.